1620 B7U9 speedpatch DIED

vbimport

#1

I had the drive for about 2 months and burned about 20 dvds. The drive always worked perfectly both reading (with the great speepatch) and burning.

Last week I didn’t used the burner since I went on vacation. My brother used the PC but he always uses the Nec 3500. Now the drive is blinking the green light always until the eject button is pressed. Then the green led disappears and I ear a really small noise like if it tried to open the tray but the tray just doesn’t open.

I tried to open it with a clip and it opened without trouble so there is nothing stuck. After opened, if I press the eject button, the tray closes really fast (not normal). If I put a DVD it doesn’t read it.

I tried changing the firmware but after trying 2 I gave up: it installs the firmware normally but the problem remains.

How does a flawless drive get this bad without even being used?

Is there something else I should try?


#2

Have you tried to flash drive in DOS with The Dangerous Brothers DOS-flasher and .cvt firmware?

BTW, no drive “dies” by it selve, there must have been something else causing this.

:wink:


#3

Great pinto, great.
I have the drive for less than a month and I have burned over 100 disks with no problem. Maybe your brother was a bad boy ;).


#4

@Mustang, I think your brother molested the drive :slight_smile:


#5

Doing something simple like opening the tray creates like 5 or 6 errors in the Windows event viewer saying “The driver detected a controller error on \Device\CdRom0”

There are no errors in the last week so I guess the drive wasn’t used. No matter which firmware I use the drive just refuses to work. I even changed the power plug connected to the drive but that didn’t make any difference.

I guess I’ll have to take back to exchange. A process that will take a month :Z


#6

Try those:
Error


#7

Your brother might have downloaded you a nice virus, run a complete virus scan and also check for malware.


#8

ha…this is a new one…