137 barrier in harddisk enclosure

vbimport

#1

Hi all, I have bought a new 300GB seagate 7200.9 pata harddisk, and tried to plug in to my 2-3 years old macpower icecube 3.5" combo harddisk enclosure… but in linux / windows xp, it can only be recognized as 137GB one (tested in 3 computers, intel and amd based, both firewire and usb).

Then I tried to use a usb-to-ide cable, the harddisk can be recognized correctly (about 280-290GB).

To test another enclosure, I tried my 5.25" one, which I placed my dvdrw in it. And at this point, the harddisk can be recognized correctly!! It uses the same oxford 911 chipset, but the “date” (actually I don’t know it is the date or not) printed on the chipset is different.

I tried to update firmware of the icecube to 3.7 / 3.8 / 4.0, all have no luck in recognizing correctly…

Does anyone have a solution to the above problem?

Thanks!!


#2

I think its more to do with Windows XP…update ur system to SP2…I had a similar problem with a Hard drive and through someone learnt that win Xp has a Storage Barrier of 137 GB…Updating your system to SP2 will help the OS recognize the rest of the storage space…


#3

Hi,

if you read his posting carefully, he indeed narrowed down the problem to the enclosure. That problem is OS independent.
Also, drives connected via USB are not affected by the known 137GB barrier of older Windows versions.

Michael


#4

Hi,

You don’t have many options, if firmware updates didn’t solve the problem.
So, with that enclosure, you’ll have to stick with HDDs up to 120GB nominal size. I think, that enclosure has an older chip revision, that is not capable to handle larger HDDs.
As last resort, you may try to ask the manufacturer, if there is any solution, but I doubt that.

Michael


#5

I had a similar problem on an older machine running Win2K. I downloaded a HDD prep util from Seagate. It did the trick.