1213 external enclosure issues; looks like the days of externals

vbimport

#1

are numbered…it wont transfer fast enough to burn at 12x…sigh. :Z would this be a limitation of my intio chipset or just firewire/usb2 in general?


#2

Just imagine it at 16x. :eek:


#3

im wondering if the new oxford chipset would transfer quicker? if this is indeed a limitation of the current firewire/usb2 architexture then we prolly wont be seeing many 12x and higher external burners.


#4

I get benchmarks of 22MB/sec on USB2 and 30MB/sec on firewire with the Oxford chip. That’s for reading, writing is more like 20MB/sec on either. (HD speeds) That should be more than adequate for 16x.

You might be seeing some PCI bus bottleneck, what are your buffers doing? I wonder if the problem is that it won’t sustain a steady speed.


#5

my device buffer is fluctating…my read buffer is steady…so its not the harddrive transfer. :iagree:

also maybe i should bump up the transfer rate in decryptor to 64 bit…not sure why its at 32.


#6

The 30MB/s on Oxford chip is impressive, fast enough even for the early generations of Blu-ray drives.


#7

I had problems running the TDK 1280 on my external Newmotion Oxford 911 box when burning the Imation 8x (Ricoh) media at 12x too. It kept slowing down to 6x, not even 8x but the funny thing was that 8x burning on the same media was fine so I ripped it out and installed it internally.

Then I realised that I had not updated the Oxford 911 firmware since I bought it and promptly took it from version 2.7 to 3.8 - too lazy to test if that helped now tho’.


#8

I have just received the enclosures. :slight_smile:


#9

How do u do that? I should prob look into it. All week I’ve been burning at 8x on my external burner. I swapped the burner for a liteon 165 rom drive to test the max read speed (hit 10x then throttled itself down to about 9x).

This is with oxford 911 chipset in the enclosure, and the built in firewire controller on my p4 1.8M laptop.

Now that I’ve put my burner back in, 6x is ok, but at 8x I get lots of under runs. My read buffer from the hard drive is always full. Given that it used to work, but now it doesnt, do u think that it could be that 32-64 bit transfer rate in decryptor (I tried my burning in decryptor, haven’t used nero yet)

EDIT: Tried to update the firmware on a a different enclosure with 911 chipset n it died, where can I get safe firmware updates for a windows machine please?


#10

dvd decryptor defaults to 32bit transfers you can change it to 64bit seems to help.


#11

Someday if I’m really bored, I’ll swap a 12x or 16x drive into one of my Oxford boxes and see what’s up. That’s the nice thing about dual-link boxes, you can see what works best.


#12

Thanks a LOT Jamos :bow:. Just got in n tested what u said with the 64k transfer and its hitting 8x again now no probs.
(with that knowledge, I tried my usb2 case again with the 64k mode on, but it still couldn’t handle >4x… ahh well, was worth a shot, but only TOOOO glad that my firewire is up to scratch again)


#13

booma

I have ads dual USB2/ieee1394 and noticed something interesting , with my liteon 832 in it if i run it usb2 I have hard time even keeping up with 8x but if run the same case and drive with ieee1394 it does fine I have read that USB2 uses a lot of cpu overhead, maybe you problem is not so much the encloser or chipset but USB2 it self. I even went so far as buy whole new USB2 card just see if it was my hardware, but it made no difference, im pretty sure USB2, for dvd burns over 4x is not as good as ieee1394


#14

which brings up the point is it the software that needs to transfer bigger blocks now with these new faster rate drives…ie should we see 128k bit transfers next so our usb2/firewire will keep up we can always increase our read buffer to catch up.


#15

ive found better results in general with firewire than usb2


#16

i notice decrypter has read buffer of 20mb wonder if setting it to something larger 40mb would be good idea im talking about the i/o tab sameplace we set the rate from 32k to 64k


#17

All USB controllers are not equal, so I’d expect to see a lot of variation on actual transfer rates. And since they run on the PCI bus, there’s a lot of potential for bottlenecks, especially if something else is running on the bus at the same time, like HD’s. You guys got me curious now, guess I’ll have to try 12x and 16x on mine and see what happens.


#18

i went out yesterday and bought a new Oxford chipset enclosure to test my 1213 same results fails at anything much above 8x.

@ken my read buffer never wavers so i doubt its having issues with keeping up…i usually get up to 40k transfers from my SATA drives. but you should bump it up past 20meg. escpecially if your multi tasking like i do. :stuck_out_tongue:


#19

Interesting points indeed.
It really is funny that now the software is the limit of these data buses. I’d never have imagined it - I thought from the bus was there, it’d get maxxed. But I guess protocol is what drives all hardware.
Ken, I’ve experimented with buffer sizes up to 80 megs in decryptor and in nero. As expected, they didn’t make that much difference, as the problem was never getting data off the hard drive, but putting it on the disk


#20

Ya i have set it to 40mb think thats should do, not like i dont have the room at moment my HDD ata/133 80gb is only about 1/3 full