1004im stuck in pio, refuces to use dma

vbimport

#1

I have a 1004 fw.48 at primary master and it simply refuces to use dma.
The concequense is that dvd’s will only be burned at about 1.5 speed, and cd’s at about 7.8.
You will understand that i’m not very pleased about that.
I’ve already uninstalled the primairy ide-channel, but that didn’t do the job.
I believe that all my settings are correct, at advanced options set that it should use dma, and in the BIOS it is also enabled.
When I connect a cd-rom drive it will use dma.
Does anyone have got an idea what’s going wrong?

TIA


#2

Tried it as Secondary master? That may help.

I’ve had no DMA problems with BTC drives here so I do not think it’s a problem with your drive.


#3

I have the same problem using the 1008 with firmware 0055.
Only PIO modus is running. Tried as primary slave and secondary slave.
What can I do befor the new firmware comes out?

Greets


#4

Well, at your advice I tried it at secondary master, and still no DMA :sad:


#5

Where is the differenz between master and slave for running in DMA Modus ?

And my 1008 runs in DMD while using the 0054 firmware.

Greeting

Firerunner


#6

have you checked your bios settings??? have you tried set to dma mode there.?

sorry i´ve to read better, you already tried this.

you can try to set the drive to secondary master, with no second drive on the ide cable.

what ide cable are you using, it´s maybe the cable


#7

> you can try to set the drive to secondary master, with no second drive on the ide cable.

tried that, no result

> what ide cable are you using, it´s maybe the cable

It’s not the cable, i’ve connected an other drive to it, and that drive does not have any probs with dma


#8

Originally posted by firerunner
[B]Where is the differenz between master and slave for running in DMA Modus ?

And my 1008 runs in DMD while using the 0054 firmware.

Greeting

Firerunner [/B]

And it didn’t work with .55?

So if I see it correct my problem could be a firmware problem? Any other people problems with .48?


#9

How to force the drive to use DMA:

  1. Go to the Device Manager
  2. Remove the drives attached to the secondary IDE controller
  3. Remove the secondary controller/IDE port
  4. Reboot Windows

After reboot Windows will recognize you drive(s) as DMA, not PIO. At least it worked for me.

Cheers,
Peter


#10

Too bad, I’ve already tried that trick, and it didn’t help.


#11

hi make sure your original drive is nt set up as line select which would cause this problem new comp use line select settings instead of master slave


#12

Originally posted by Meester[NL]

[QUOTE]what ide cable are you using, it´s maybe the cable

It’s not the cable, i’ve connected an other drive to it, and that drive does not have any probs with dma [/QUOTE]
The BTC drive may be pickier than the one you tested.

Are you actually using an 40 pin, 80 wire IDE cable? Or, if you do, could it be that your cable is longer than 45 cm?

Regards, Martin A


#13

Hi guys,

All of you who are experiencing problems with DMA mode (falling back to PIO mode or refusing to use DMA mode totally), please send me an e-mail at support@btceurope.nl

My first guess would be that this problem must have something to do with the IDE interface.

Please let me know all about your system, especially mainboard/chipset type, the IDE drivers you are using, the settings in your mainboard BIOS regarding IDE, etc.

Some endusers have reported problems with their IDE drivers and have been able to solve some problems by switching to the standard Microsoft Windows IDE drivers. You might want to give it a try.

Thanks in advance for your response.

Marco
BTC Europe Support


#14

Nice of you to decide to reappear, Marco. :slight_smile:


#15

are you using win 2000 ? if yes then its “normal” because win doesnt set automaticly to dma (on all drives)… you have to “force” the drive in the properties tab of the pri. or sec. ide-channel (depends on with channel the drive is connected). i had this problem with an lg-cd-burner and win2000!


#16

Originally posted by TeT
are you using win 2000 ? if yes then its “normal” because win doesnt set automaticly to dma (on all drives)… you have to “force” the drive in the properties tab of the pri. or sec. ide-channel (depends on with channel the drive is connected). i had this problem with an lg-cd-burner and win2000!

Using XP PRO SP1

And I wish I could force the d*mn thing :stuck_out_tongue:


#17

Originally posted by Centurio

[QUOTE]
[B]It’s not the cable, i’ve connected an other drive to it, and that drive does not have any probs with dma

The BTC drive may be pickier than the one you tested.

Are you actually using an 40 pin, 80 wire IDE cable? Or, if you do, could it be that your cable is longer than 45 cm?
[/B][/QUOTE]

My pc is really getting messy from the inside, but I’ve switched some cables and tried it with an 40 pin, 80 wire, 45 cm cable…and no result.
Thanks anyway for thinking with me


#18

Ok, i had the same problem too. My solution to have dma enabled was to remove the secondary slave drive from my pc and finally the BTC 1004 was working in dma, all other combinations failed.

For marco: i’ve tried different types of media but after 1 or 2 weeks all the dvd’s made with BTC are garbage! They can’t be read by anything!!!


#19

set the jumper on “cable select”.it did the trick for me.


#20

Wow i’m really tired of this piece of crap! it does not burn cds or dvds anymore, and it’s only 3 months old and only burnt 20 discs. Any suggestions?