1 GB Memory stick doesn't work

vbimport

#1

Hello yea my 1 Gb memory stick doesn’t work when i plug it in its says “Removable Disk (:H)” and when i try to open it… it doesn’t let me, and when i try to format it… it still doesn’t let me it says "Windows was unable to complete the format… It doesn’t let me do anything… can anyone help me out here???

Thanks


#2

Has it got a write protection switch and is it on?


#3

nope no switch


#4

Your problem are related to the Card Reader.

My Trust can’t read one Kingston 256 Mb SD, but the same SD Card works in another Card Reader.


#5

Im guessing this is via usb… try putting it in a different input, also (im not entirely clear on this but im sure chef will vertify this for me) weather it only supports usb 2


#6

Memory sticks can be read just fine in usb 1 readers, though the speed is substantially slower (some usb 2 are pretty slow due to the use of older controler designs).


#7

Can you try this drive in another PC, and did it come with software utility for formatting?


#8

It installes the hardware and then it still says the same thing i did this on 2 computers… one on Desktop and one on Laptop…


#9

It’s the Card Reader that can’t read memory stick.

Can the hardware you bought it to use with read the memory stick.


#10

Just possibly the memory stick could be faulty if it will not work in other computers.


#11

Yea i am guessing the card doesn’t work… it worked before i wanted to upload some of my work to another computer when i upload it to my car it worked fine… i took it out and put it in my laptop and the problem came up


#12

Impact323, information about stick’s brand and type would help. :slight_smile:

My son had the same problem a while ago with his Corsair flash memory, when using it on both USB1.1 (in school) and USB2.
Corsair flash security software reformat function fixed that problem and has not come back (cross fingers). :wink: