_NEC DVD+RW ND-2100AD burning problems

Let me preface this by saying that, compared to most of the members on this site, I’m a technological novice. In any case, my DVD writer has been having trouble burning data discs. I tried two different brands of DVD+R discs (Memorex and Imation) and neither worked, so I don’t think that that’s the issue. When I try to copy a folder containing .rar files onto the DVD so that I can burn it, I get a non-descript error message, like so:

Also interesting is that my computer indicates that the DVD has 0 bytes available on it, even though it’s blank and has never been used:

Does anyone have an idea as to what the problem may be or how this issue could be resolved? Thank you in advance for your help!

You want to burn a DVD, so install a proper burning app and use it!

Imgburn is a popular program for burning DVDs, it is also free.

Also, both Memowrecks and Imation usually resell cheap junk media. If you still have problem with Imgburn, I’d recommend trying Verbatim disks (AZO branded or made in Japan, not pearl white). Taiyo Yuden is also good, but it tends to cost more and many places sell fake TYs.

Using ImgBurn worked! Thanks a lot for your help!