Community Talk , Bug Reports & Site Feedback


Topic Replies Activity
Opera magic key is not working 9 October 29, 2014
Insulted, not sure? 24 September 21, 2014
Bug: Mark forum read 1 September 7, 2014
Unable to edit any of my posts :( 11 June 24, 2014
Broken smilies, potentially sluggish site performance [13 February 2014] 24 June 23, 2014
Opera Next v. 22 8 June 23, 2014
Are you no longer deleting accounts? 2 April 9, 2014
The update tracker (white envelope with red number) 3 February 25, 2014
Retrieve my old membership 11 January 19, 2014
Why I was banned without me having done anything wrong? please i beg another chance 5 January 19, 2014
Forum is glitchy today 74 January 17, 2014
First impression of MyCE 9 January 11, 2014
There are too many "Read First" threads in the Consumer Electronics Forum 13 January 8, 2014
Running Vbulletin on Google App Engine 1 January 5, 2014
Please Delete My Account! 16 December 20, 2013
News notifications 3 December 11, 2013
Problem logging in 1 November 21, 2013
Frontpage reaction / forum posts not showing 3 November 16, 2013
Delete my account? 53 October 17, 2013
Tapatalk installed 19 October 13, 2013
What Happened To My Forum Posts-Eh Yahosers? 35 October 13, 2013
New Forum Suggestion 8 October 6, 2013
Lost posts? 5 October 6, 2013
Funny video for Myce 16 September 15, 2013
Can We Set The "Smilies Box" In The CatBox To Stay Open Longer Than THREE Seconds? 9 September 14, 2013
Unable to view attachments 7 September 2, 2013
I can log in but can't post on main page 8 August 29, 2013
CDFreaks fans: Anyone got screenshots before Sept 2007? 5 August 21, 2013
Annoyance: forum template popup 3 August 18, 2013
Online/Offline icon 3 July 30, 2013