Old 31-10-2002   #1
MyCE Resident
 
Upp3rd0G's Avatar
 
Join Date: Oct 2001
Location: NL
Posts: 2,116
if-then-else construction in Excel formula

if (a1 = 1 && b1 = 2)
{
c1 = 1;
}
elsif (a1 =2 && b1 = 3)
{
c1 = 2:
}

I tried to get the above in an Excel formula for field C1:

=IF((A1=1)*AND(B1=2);1;*OR(IF((A1=2)*AND(B1=3);2;999)))

It doesn't work. Somebody any idea?
__________________
Upp3rd0G is offline   Reply With Quote
Old 31-10-2002   #2
MyCE Resident
 
Upp3rd0G's Avatar
 
Join Date: Oct 2001
Location: NL
Posts: 2,116
Problem solved.

=IF(AND(A1=1;B1=2);"1";IF(AND(A1=2;B1=3);"2";IF(AND(A1=3;B1=4);"3";IF(AND(A1=4;B1=5);"4")) ))

Case closed.
__________________
Upp3rd0G is offline   Reply With Quote
Old 31-10-2002   #3
New on Forum
 
Join Date: Oct 2002
Posts: 10
Possible solution

=ALS(EN(A1=1;B1=1);1;ALS(EN(A1=2;B1=3);2))
With English version of Excel:
als = if
en =and


[edit]
This is an English forum, no Dutch allowed!
Edited it for you this time.
[/edit]

Last edited by Da_Taxman; 31-10-2002 at 19:27.
solskjaer is offline   Reply With Quote
Old 31-10-2002   #4
Retired Moderator
 
Join Date: Jun 2002
Location: Deadwood
Posts: 11,533
those parenthesis will get you every time
rdgrimes is offline   Reply With Quote
Old 23-06-2008   #5
New on Forum
 
Join Date: Jun 2008
Posts: 1
Re: if-then-else construction in Excel formula

i want to construct a formula.

CALCULATE THE TAX BASED ON 0.85% OF CURRENT SALARY IF CURRENT SALARY MORE THAN 25000.

how to construst above formula using IF.
can anyone help me?
zoey90 is offline   Reply With Quote
Old 15-08-2008   #6
New on Forum
 
Join Date: Aug 2008
Posts: 1
Re: if-then-else construction in Excel formula

is it possible for Excel to convert digits to words? for example 1,000.00 to One Thousand?
seiwakai5378 is offline   Reply With Quote
Old 22-01-2009   #7
New on Forum
 
Join Date: Aug 2007
Posts: 2
Re: if-then-else construction in Excel formula

Quote:
Originally Posted by seiwakai5378 View Post
is it possible for Excel to convert digits to words? for example 1,000.00 to One Thousand?
Yes it is.

=IF(A1=1000,"One Thousand","")
the ditch doctor is offline   Reply With Quote
Old 22-01-2009   #8
New on Forum
 
Join Date: Aug 2007
Posts: 2
Re: if-then-else construction in Excel formula

Is it possible to use a "if/then" formula to reference and list the contents another cell?
ie: =if a1=x then b1 = c1
the ditch doctor is offline   Reply With Quote
Reply


Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Construction Destruction kalas Copy Protection List 5 23-11-2007 08:30
Stupid construction Bloodstar007 Living Room 1 19-11-2004 11:24
Lite-On -- flimsy construction? BlueWinterWaves LiteOn / PLDS / Sony Writer 29 06-08-2002 00:08
Serial/Crack ScreenSaver Construction Set aub... Administr8or Dutch: De Woonkamer 4 05-06-2000 19:01


All times are GMT +2. The time now is 12:53.
Top